Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

App buttons do not work - Nexus 5 - Sound Platform 2

Dave Mar 21, 2015 08:29AM CDT

Good morning.

As mentioned above, I have a new SP2, and a Nexus 5 with Android 5.1 installed

I've downloaded the app and done the pairing steps.

I know that the SP2 and my N5 are seeing each other
- I can use other apps to play music on the SP2 (such as Rocket Player)
- If I start the app, it has the 6 buttons (rev/play-pause/fwd - mute - vol -+). If I then turn on the SP2, the other three buttons magically appear - Power/Source/UQ3

But the buttons have no effect on the SP2. And even weirder, turning the SP2 on stops the buttons from being able to control playing the N5

Here's the sequence:
- SP2 and phone both off
- turn on the N5
- Start the Soundfreaq app
- Start a song playing - plays fine. Use >>| to get to the next song, volume buttons to control the volume - all works fine.
- turn on the SP2
- the current song stops using the phone speaker, and starts on the SP2
- the extra buttons show up on the App
- None of the buttons on the app work anymore. Can't pause, play, skip, vol change - nothing. The music keeps playing thru the SP2
- Shut off the SP2 - music starts on the phone speaker again, the extra buttons disappear, and the remaining buttons work again.

So weird.
What's up?

Up 0 rated Down
Lisa Mar 23, 2015 02:39PM CDT SOUNDFREAQ Customer Service Ninja
Dave, thank you for being a Soundfreaq customer, and I'm sorry to hear you are experiencing Soundfreaq app issues with your Android. Is this a new out of box issue, or were you able to use the app in the past?

Please make sure you are using the black Soundfreaq app, and not the blue Remote app.

The behavior with the appearing and disappearing Power/Source buttons is correct. These buttons will only appear when when the speaker is connected via Bluetooth, or in other words, on.

If you have not done so already, please try resetting the Bluetooth connection by removing "Sound Platform 2" from Bluetooth > Devices on your Android, before re-pairing. If the issue persists, please also try deleting the Soundfreaq app before reinstalling.

Please let us know your troubleshooting results, and thank you for your patience. Any questions, please let us know.
Up 0 rated Down
Dave Mar 28, 2015 01:17PM CDT

No - this is the first try. And yes, I'm using the app with the black icon.

The SP2 is brand new - bought it last week at a local chain store. It's model SFQ-06.

The Nexus 5 has been in the house for a few months - lost it, bought another, found the first. The first went back into the box until this week. I did a hard-reset-erase-all type action, took out the SIM card, installed Android 5.1 - it's just a wi-fi enabled PDA. I was planning for it's sole function to be the remote for the SP2. Pretty pricey remote...

The app's 'about' says
Version :0.0.4
Code: R4
your email
your web

I've only downloaded four apps - Rocket Player, PowerAmp, Soundfreaq, and Firefox.
= =
For doing the suggested reset:

It's hard to get the N5 to forget about the pairing! Not an obvious path at all, but I finally found 'forget'. Even then, it still showed the SP2 as nearby. But when I tried to connect, it tried for a few seconds, and then said "Couldn't pair with Sound Platform 2 because of an incorrect PIN or passkey"

I hit pair on the SP2, and then connect on the N5, and it connected again - same symptoms.

I uninstalled Rocket Player, PowerAmp, and Soundfreaq apps. I re-installed only Soundfreaq. Did the 'forget' again - re-paired - same symptoms.

I can tell that the app is registering the button pushes - it switches from just the button to a 'depressed' button with two rings. (Hmm - the pause/play button doesn't have the depressed animation, either mode, even when it's working for just the N5 - probly normal as well.)

I tried the 'connect device' option under 'menu' - makes the buttons go away and reappear - but no change.

Whaaaat's next :-)

Dave.
Up 0 rated Down
Lisa Mar 28, 2015 01:21PM CDT SOUNDFREAQ Customer Service Ninja
Dave, I apologize for the mistake on my part. Please use the blue Remote app, not the black: https://play.google.com/store/apps/details?id=hk.com.beautiful.Qing.SOUNDFREAQ&hl=en

Please let us know if the issue persists.

If the master device is asking for a passcode, please try 1234.

Please know other apps shouldn't affect how the Soundfreaq app works. Often times if you are not adjusting volume or changing sources, the default app from which you are streaming music (such as RocketPlayer), is more convenient to use than the Soundfreaq app.

Please let us know your troubleshooting results. Thanks again for working with us.

Post Your Public Answer

Your name (required)
Your email address (required)
Answer (required)
support@soundfreaq.com
http://assets3.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete